Now Compatible With Mozilla and IE

Just a little update before I start reading for my damn exams again – a few glitches were corrected and the site is now working smoothly with Mozilla and IE 6.0.

By Vegard Skjefstad

Leave a Reply

Your email address will not be published.